Debian image available?

On April 25th, MQ-Quad was announced:
“with Debian/Ubuntu/Android10TV ready”
As for now, I can see only Tina-Linux image link on product page. And what about Debian?

1 Like

There is a Debian image listed here now: Mango Pi, Tiny and Elegant SBC | mangopi_mqquad

However, I don’t get any video output when booting it up.

EDIT: I was able to SSH into it using root / orangepi

try to check the hdmi cable

I was trying to SSH login as you suggested but I had no luck. Did something has changed?
I tried root and password orangepi but didn’t work.
Could you help please?

I have an output on the HDMI, but no network when using my USB-C hub with Ethernet.
I don’t have the mouse either on that hub. I guess the module corresponding to the chip that handles all that is not in that build. :person_shrugging:
This hub works with the MQ-Pro running Armbian though.

Is there any way to preconfigure the WiFi on the SDCard before booting?

I saw the Debian image here and it is working great for me, but it is a bit … bulky, Is anyone intending to post a “minimal” image so that we can simply pull the stuff we need? Either Debian or Armbian , any RedHat distros in the works? I am running headless, so ssh and cockpit are really all I need once I get going.


Mine is working fine with a USB-C to microUSB adapter and a mini-hub from my Pi. Have you tried a different USB to Ethernet adapter? Keyboard and mouse work as well.

1 Like

I have also tried with a hat from Waveshare but it does not work either (no Ethernet, no USB working).
What I’d like is just a way to select a WiFi network, then only keep the USB-C power and get rid of all the rest. :person_shrugging:

poddingue …

Which OS image are you using. The only one I can get to boot is the debian image linked to from this page (Debian_bullseye_desktop_xfce_linux5.16.17_mqquad_root_orangepi.img.gz) and I would really like to see a “minimal” release of this as I run headless. HDMI display works with XVCE from this image, as does ssh.

WiFi runs just fine on mine after using nmtui to configure it.

Which Waveshare display? That’s next on my list. Other than a very limited (1) choice of boot media, stuff seems to be working OK. It just looks like I need to figure out how to generate a working boot sector. Documentation on how to load up a distribution would be great if somebody could post a pointer.

I’d be glad to supply it once I figure out how to build a working boot image.

$ hostnamectl
Static hostname: MangoPi-2
Icon name: computer
Machine ID: a5726a42a4604b13aeb7f137ea4ee8e5
Boot ID: 2b759cbf56cd4ae7b4ec521f8c783525
Operating System: Debian GNU/Linux 11 (bullseye)
Kernel: Linux 5.16.17-sun50iw9
Architecture: arm64

I cannot get any ARMbian images to boot.

1 Like

Yes, the image that boots, and shows up a display for me is Debian_bullseye_desktop_xfce_linux5.16.17_mqquad_root_orangepi.img.gz.
Of course, without interaction, it starts the screensaver after some time.

Unfortunately, as the USB hub and hat don’t work for me, and Ethernet doesn’t work for me either, I’m stuck.
If you ever know how to configure the distro to start with a known WiFi network (as we did back in the day with Raspbian and Armbian), that would help.
The hat from Waveshare does not have a display on it, just a few USB ports and a RJ45 one. :person_shrugging:

That HAT also has a jumper that goes from the USB port on a Pi 0 to the board itself, and there is nothing to plug that into except the USB-C port. A suitable cable MIGHT work. I got mine up by plugging the HDMI connector into a monitor and then plugging a USB C port into hub connected to a mouse and keyboard. The hub I used for this also has an ethernet.

This is the adapter (hub) I used:
Ethernet Hub and USB Hub w/ Micro USB OTG Connector (

I used it with the standard Raspberry Pi uUSB to USB-C adapter.

[USB micro-B to USB-C adapter, White -]
(USB micro-B to USB-C adapter, White -

It picked up an IP address using DHCP, but it shouldn’t matter if you have a display and keyboard. Open up a terminal window and run nmtui to connect the WiFi

Plan B:

root@orangepizero2:~# sudo nmcli device wifi list
0C:51:01:E3:5A:9A Anthony’s Wi-Fi Network Infra 11 195 Mbit/s 77 ?? WPA2
9A:0B:7C:E3:DB:A8 – Infra 11 195 Mbit/s 59 ?? WPA2
. . .
FC:9C:98:09:9A:EA ARLO_VMB_4006759516 Infra 2 130 Mbit/s 15 ?___ WPA1 WPA2
FA:8F:CA:66:E0:8A Bathroom TV.v Infra 6 65 Mbit/s 12 ?___ –

root@orangepizero2:~# ip -br address show dev wlan0
wlan0 DOWN

root@orangepizero2:~# sudo nmcli device wifi connect ‘name’ password ‘whatever’ ifname wlan0
Device ‘wlan0’ successfully activated with ‘d08508dd-c454-4721-b390-7b9785703d33’.

root@orangepizero2:~# ip -br address show dev wlan0
wlan0 UP fe80::2ef:317c:8c06:d096/64

1 Like

Thank you. What is the chip that supplies Ethernet & USB hub on this adapter?

I have no idea. What I will do later is take a standard keyboard with a built in hub (Dell, because I work for them) with a USB mouse attached to it and see if that works. I suspect that the USB itself is not at issue. Once you can run nmtui, which is a curses based utility, I think you’re off to the races with WiFi, but because they provided a bloated distribution with X-Windows as configured, you’re stuck until you can click a mouse and open a window.

One of my Mango Pis came with a USB-C to A (female) adapter, so I’ll use that. I also have a USB-C Orico hub, but I don’t think which USB hub is used is important. I have the same Waveshare hubs too, but would have to pull one off a Pi Zero. Make sure you use the middle USB-C port to connect to. The outer one is for power (port usage is opposite to that of the Pi Zero USB gadget which powers/boots off the center microUSB port).


1 Like

Thanks @bracka .
I think I will order asap a USB-C to USB-A adapter, and I should be good to go.
Does the old trick to use CTRL+ALT+F[1…6] in order to get access to text console work for you?
That would allow me to use just a keyboard with an adapter and nothing else, then configure the wifi and forget about all that. :blush:

yes: that worked for me

1 Like

Thanks a lot.
I just received my adapter, used the console trick, and I am now a happy camper. :partying_face:
I also tried another USB-C hub without much luck. :person_shrugging:
Anyhow, I now have a working machine connected to my WiFi network. :relieved:

You had a real run of bad luck there: I had trouble finding anything that DIDN’T work! (LoL), Now if I can only figure out how to make an SD card image that boots and isn’t bloatware. It doesn’t make much sense to upgrade from a Pi with 512MB and then suck up half a gig with X Windows and stuff I don’t need.

Nice little machine otherwise. Enjoy!

1 Like

I used the systemctl set-default trick to get it to boot without X.
Now I have to tackle getting rid of all the packages linked to X. :person_shrugging:

It looks like the image is built on top of an existing Orange Pi Zero 2 configuration…
If only we could get the build system, or get MangoPi to give it to Armbian, so that we get something more configurable :thinking:

Wifi: With the latest minimal image, after you have created your micro SD, mount it on a Linux box (or get a driver to mount ext4 on Windows.) Go to /boot. There’s a template file in there, just edit that and rename it without the .template (must be root to do that), and eject and boot your MangoPi. Simples.

Note the first boot takes a long time, and in my setup for whatever reason, the router doesn’t report seeing the board – but it does give it an address. What I finally did, after waiting 10 minutes or so, was pull the plug, and put the SD back in my laptop. In /var/log/syslog, you can see it starting up (giveaway is the file has today’s date and time, NTP came up OK). Saw the IP it was getting, replugged it in, and SSH’d to it - works fine.