Working OS image with display for MPi-MQ1PH

hello everybody,
I received today the Mangopi MQ1PH pink and I am looking forward to using it. However, I have problems getting it to boot or better to see the OS on my monitor. I tried to flash several different images on an SD card with no success. Nither the official tina-d1h-mq-pro-overlay-hdmi-wifi.img nor RVBoards_D1_Debian_img_v0.4.1.img worked. When I plug in the power first a green LED lights up followed by a blue LED. The D1 chip is also getting wormed but I can’t get a display on the monitor. So I assume that it actually can boot.

Does anyone have a working image file that allows using a monitor with a graphical interface available? Or is there a method by which I can connect to the mango pi headless by another computer when it is not connected to the network?
Thanks

1 Like

Thanks for the heads up. I’ve just got mine today, and was precisely thinking using the RVBoards image. I will let you know how it goes once I manage to get a mini-HDMI adapter first. :wink:

There’s also a Mainline Linux for D1 and a Mango_Pi groups on Telegram, so perhaps (if you haven’t joined yet) you could get there also some support.
Cheers!

I’m lurking to see if anyone has success before I purchase one. I hope it works for you. If it does please post back and let us know what worked.

Thank you for the advice, I will try to Mainline Linux for D1 and check the Telegram groups

Sure, I will post my progress here. I still did not get it to work yet. I will let you know

FYI armbian is now working on MQ Pro Armbian on the MangoPi MQ Pro! | Bret's Tech

3 Likes

dear all,
thank you so much for all your replies. Issue is resolved
The armbian os that Ericmigi shared works as described on the Bret’s website link. Note I had to download the image from a mirror since the direct links on the page resulted in a download of only 54 bites. I used this mirror: Index of /mangopi-mq-pro-armbian/ and flushed the headless image: Armbian_22.08.0-trunk_Nezha_jammy_current_5.19.0.img.

Notes:

  • one of my friends compiled a tinna linux RISC-V image for me as described on the official page. We can tell it is booting but still no HDMI signal on all kinds of monitors that we tried.
  • I also faced HDMI signal issues in the beginning with this armbian image. (similar to what I faced with installing armbian on a radxa zero). I managed to get a signal by first plugging it into an HDMI resolution screen during boot-up. No signal. I power off and power on the screen and it is flickering. then I plug in the mangopi while still running into my 2K screen and I see the boot text coming. at the next restart, my HDMI screen works fine. I have no idea why it works
2 Likes

thank you very much. It solved my problem

1 Like

Ubuntu 22.04 LTS Server for RISC-V officially support D1 now. Can be downloaded from Download Ubuntu for RISC-V Platforms | Ubuntu
I have tested it. HDMI worked fine on MangoPi Pro. USB Lan (realtek-based) also worked out of box.