Armbian trunk for MQ Quad H618

I’ve obtained this image from some MangoPi discussion group from China.
I do not own the credit for creating this but it seems there is needed for such image for other H618 user.
So, here come the link as below.

I had tested it works for my H618 mangopi board, but no guarantee it works for you.

If possible, I hope the admin could host the file in official page for sharing as google drive have download limit.

@EZPi @admin

Thank you!! Will check soon and update

what are the login user and pass??
thanks boots on the h616 also

it’s a standard armbian image, so the credential shall follow normal armbian system…
in short it is root and 1234

I am trying to find out a bit more about this since the pointers on the MangoPi site do not yield a bootable image. I am in the process of downloading this one. Is this intended to become a community supported ARMbian image and can the build tree be downloaded somewhere?

I have both H616 (2) and H618 (1) variants of the board.

@disablewong

Are you aware if there is any meaningful support page for these boards that is not in Chinese? The advertised home page is pretty sparse, and the downloads are “unconventional”.

Thank you for your help so far !!!

Regards,
Tony

Update:

  • image did not boot from an 8G microSD, switched to a 16G microSD
  • H616 board boots successfully, but fails after upgrade
  • H618 board hangs consistently

H616 failure:(after apt update/upgrade)

switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1…
Found U-Boot script /boot/boot.scr
3202 bytes read in 2 ms (1.5 MiB/s)
-## Executing script at 4fc00000
U-boot loaded from SD
Boot script loaded from mmc
180 bytes read in 2 ms (87.9 KiB/s)
Failed to load ‘/boot/dtb/allwinner/sun50i-h616-mangopi-mcore.dtb’
libfdt fdt_check_header(): FDT_ERR_BADMAGIC
No FDT memory address configured. Please configure
the FDT address via “fdt addr ” command.
Aborting!
Failed to load ‘/boot/dtb/allwinner/overlay/-fixup.scr’
12992556 bytes read in 539 ms (23 MiB/s)
22325256 bytes read in 926 ms (23 MiB/s)
Moving Image from 0x40080000 to 0x40200000, end=417c0000
-## Loading init Ramdisk from Legacy Image at 4ff00000 …
Image Name: uInitrd
Image Type: AArch64 Linux RAMDisk Image (gzip compressed)
Data Size: 12992492 Bytes = 12.4 MiB
Load Address: 00000000
Entry Point: 00000000
Verifying Checksum … OK
ERROR: Did not find a cmdline Flattened Device Tree
Could not find a valid device tree
SCRIPT FAILED: continuing…
libfdt fdt_check_header(): FDT_ERR_BADMAGIC
BootOrder not defined
EFI boot manager: Cannot load any image
ethernet@5030000 Waiting for PHY auto negotiation to complete… TIMEOUT !
missing environment variable: pxeuuid
missing environment variable: bootfile
Retrieving file: pxelinux.cfg/01-02-00-52-d8-18-ae
ethernet@5030000 Waiting for PHY auto negotiation to complete… TIMEOUT !
missing environment variable: bootfile
Retrieving file: pxelinux.cfg/00000000
ethernet@5030000 Waiting for PHY auto negotiation to complete… TIMEOUT !
missing environment variable: bootfile
Retrieving file: pxelinux.cfg/0000000

H618 failure:

. . .
[ OK ] Started Load/Save RF Kill Switch Status.
Starting Load Kernel Module chromeos_pstore…
Starting Load Kernel Module efi_pstore…
Starting Load Kernel Module pstore_blk…
Starting Load Kernel Module pstore_zone…
Starting Load Kernel Module ramoops…
[ OK ] Finished Load Kernel Module chromeos_pstore.
[ OK ] Finished Load Kernel Module efi_pstore.
[ OK ] Finished Load Kernel Module pstore_blk.
[ OK ] Finished Load Kernel Module pstore_zone.
[ OK ] Finished Load Kernel Module ramoops.

@void0naught

You wrote:
what are the login user and pass??
thanks boots on the h616 also

If you have a console on UART0 it asks you to set the root password and makes you create an admin user on first boot.

Tony

Thank you for sharing this, it is greatly appreciated.

Unfortunately, my h618 doesnt bootup either, Im getting about as far as @bracka.
Sometimes attaching a hdmi display gets a few more modules to load, and I got it to boot once, but it seems to consistently hang around [ OK ] Finished Load Kernel Module ramoops message

Would you mind linking to the other forum/thread where this was being worked on?

(I did check to see if my board is still working after all these months, it booted into android just fine)

ops, let me take a look maybe the image was not right.
let me take a look during my chinese new year holiday.

Ok, thanks again for doing this.

If you’d want any logs/reports from my hardware, I’d be happy to provide them

Had been busying in visiting relatives and spent time with family during the Chinese New Year, so sorry for my late.

Here come two more images for trial:

Bullseye Armbian

All credits go to sputnik @ Chinese Mangopi group! I just relay his great armbian image here!

Bookworm DietPi

I was able to boot with my board.
Please feel free to play with them :slight_smile:
Wish you all have a great and healthy Year of Loong(Dragon)!!! :smiley:

just feel free to test the new images~ :slight_smile:

Generic Device (aarch64) | IP: 192.168.3.243
┌──────────────────────────────┤ DietPi-Config ├───────────────────────────────┐
│ DietPi-Benchmark | https://dietpi.com/survey#benchmark :                     │
│  - CPU Performance   : Duration = 10.55 seconds (lower is faster)            │
│  - CPU Temp          : Idle = 48'c | Full load = 71'c                        │
│  - RootFS            : Write = 19 MB/s | Read = 22 MB/s                      │
│  - RAM               : Write = 617 MB/s | Read = 800 MB/s                    │
│                                                                              │
│ Additional benchmarks:                                                       │
│  - Custom Filesystem : Write = Not tested MB/s | Read = Not tested MB/s      │
│  - Network LAN       : Transfer rate = Not tested MB/s                       │
│                                                                              │
│                    ●─ DietPi-Benchmark ────────────────────────────────────  │
│  DietPi-Benchmark  : Starts CPU, RAM and IO benchmark suite. Scores can be   │
│                    ●─ Additional benchmarks ───────────────────────────────  │
│  Custom Filesystem : Benchmark IO performance from a selection of mounted d  │
│  Network LAN       : Benchmark LAN performance using 2 DietPi systems.       │
│                                                                              │
│                                                                              │
│                     <Ok>                         <Back>                      │
│                                                                              │
└──────────────────────────────────────────────────────────────────────────────┘

you can compare your board performance with others on DietPi-Survey statistics

No worries, im just glad theres a chance it’ll work. This sbc has been an exercise in patience, lol. As for these builds, Im getting somewhere, but things arent quite right.

I started with DietPi:
Most boots hang, but occasionally I get a login prompt. I can login (root/dietpi) but afterwards it always hits me with

Debian GNU/Linux 12 DietPi ttyS0

DietPi login: root
Password:
Linux DietPi 5.19.4-sunxi64 #22.08.2 SMP Thu Jun 1 17:42:13 CST 2023 aarch64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/⁎/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
 ─────────────────────────────────────────────────────
 DietPi v9.0.2 : 21:01 - Fri 02/16/24
 ─────────────────────────────────────────────────────
 - LAN IP : Use dietpi-config to setup a connection (eth0)

 DietPi-Update
─────────────────────────────────────────────────────
 Phase: Checking for available DietPi update

[FAILED] DietPi-Update | Checking IPv4 network connectivity
 - Command: ping -4nc 1 -W 10 IP

Idk what is relevant, so I decided to just upload uart console output (logs?) on pastebin. (lol, theres aslo alot) There is an example of the hang condition, and the freeze after login (for the sake of this post, a hang is when the system freezes and the heartbeat led and cursor stops blinking/moving. A freeze is when the system stops accepting input, but the cursor or heartbeat is still going. At this point I’ll wait 5 to 10 minutes and if it doesnt make any progress I pull power and try again) Occasionally the heartbeat goes into ‘fast’ mode, where it just seems to loop through its blink pattern much more rapidly.

Logged in and hanged on the menu, Login, interacted with menu and then it froze, Common ouptut of a hang while booting


On Armbian, where things are more inconsistent.

Most often the boot hangs, although were it hangs and whether it freezes or hangs seems to vary. Here are some examples of what Im experiencing:
Hang on boot, Another hang,
This is a freeze, with a trace and the heartbeat went into ‘fast mode’, Im not sure how to classify this but atleast theres a proper failure message?

I got it to successfully boot once and I went through initial setup, here is me logging in with ssh on WiFi: (This is more a celebration that it booted than it is useful data)

 __  __                           ____  _   __  __                    
|  \/  | __ _ _ __   __ _  ___   |  _ \(_) |  \/  | ___ ___  _ __ ___ 
| |\/| |/ _` | '_ \ / _` |/ _ \  | |_) | | | |\/| |/ __/ _ \| '__/ _ \
| |  | | (_| | | | | (_| | (_) | |  __/| | | |  | | (_| (_) | | |  __/
|_|  |_|\__,_|_| |_|\__, |\___/  |_|   |_| |_|  |_|\___\___/|_|  \___|
                    |___/                                             
Welcome to Armbian 22.08.2 Bullseye with Linux 5.19.4-sunxi64

System load:   2%               Up time:       13 min
Memory usage:  14% of 984M      IP:            192.168.0.105
CPU temp:      58°C             Usage of /:    12% of 15G    
RX today:      n/a        

[ 0 security updates available, 9 updates total: apt upgrade ]
Last check: 2023-06-01 09:47

chaos@mangopimcore:~$ neofetch
                                 chaos@mangopimcore 
                                 ------------------ 
      █ █ █ █ █ █ █ █ █ █ █      OS: Armbian (22.08.2) aarch64 
     ███████████████████████     Host: MangoPi Mcore 
   ▄▄██                   ██▄▄   Kernel: 5.19.4-sunxi64 
   ▄▄██    ███████████    ██▄▄   Uptime: 14 mins 
   ▄▄██   ██         ██   ██▄▄   Packages: 513 (dpkg) 
   ▄▄██   ██         ██   ██▄▄   Shell: bash 5.1.4 
   ▄▄██   ██         ██   ██▄▄   Resolution: 1024x768 
   ▄▄██   █████████████   ██▄▄   Terminal: /dev/pts/0 
   ▄▄██   ██         ██   ██▄▄   CPU: (4) @ 1.512GHz 
   ▄▄██   ██         ██   ██▄▄   Memory: 144MiB / 984MiB 
   ▄▄██   ██         ██   ██▄▄
   ▄▄██                   ██▄▄                           
     ███████████████████████                             
      █ █ █ █ █ █ █ █ █ █ █

chaos@mangopimcore:~$ 

While running sbc-bench (since I wasnt running dietpi, I figured this could generate an equivalent report), I ran into an error and wasnt able to get that image to boot again. It seemed to consistently hang with Starting Armbian memory supported logging... occasionally loading a bit more but ultimately hanging.
I’ve been unable to get armbian to boot since. I’ll keep trying, and remember to update/reboot the system next time.

I also have another trace, although I cant remember if this was from dietpi or armbian, or what the led/cursor was doing

Maybe its something simple, how are you imaging your SD cards? Ive tried using balenaEtcher and dd the file onto the /dev/mmcblk0 device.

If you encounter boot fails, try to get a better power supply.
I found that this board would be unstable if the power is not sufficient. I used a type-c 65W power supply for it. Please get a decent cable too as the current goes up, the voltage might drop with the thin cable.

For the Diet-Pi, it has got a first boot script to expand the filesystem size (to fully occupy your sd card space) and to update the system to latest state. Therefore, you would need a working network to let it carry on with the script. I’ve done it through a usb-ethernet adaptor. In theory, you could set up the wifi adaptor with dietpi-config to have a working network, I’ve tested the wifi works for my board.

During the first boot, you should press Ctrl+C to abort the script as I found that there are three packages updates would kill the image, namely armbian-firmware, linux-dtb-edge-sunxi64 and linux-image-edge-sunxi64 . Hold these packages through apt-mark hold “package name” in bash, and then logout and log-in again to continue the update should works.

For the usage of DietPi and those software, you should be able to find many of the doc on their website.

root@DietMango618:~# apt-mark showhold
armbian-firmware
linux-dtb-edge-sunxi64
linux-image-edge-sunxi64
root@DietMango618:~# neofetch
       _,met$$$$$gg.          root@DietMango618 
    ,g$$$$$$$$$$$$$$$P.       ----------------- 
  ,g$$P"     """Y$$.".        OS: Debian GNU/Linux 12 (bookworm) aarch64 
 ,$$P'              `$$$.     Host: MangoPi Mcore 
',$$P       ,ggs.     `$$b:   Kernel: 5.19.4-sunxi64 
`d$$'     ,$P"'   .    $$$    Uptime: 9 hours, 8 mins 
 $$P      d$'     ,    $$P    Packages: 224 (dpkg) 
 $$:      $$.   -    ,d$$'    Shell: bash 5.2.15 
 $$;      Y$b._   _,d$P'      Terminal: /dev/pts/1 
 Y$$.    `.`"Y$$$$P"'         CPU: (4) @ 1.800GHz 
 `$$b      "-.__              Memory: 108MiB / 984MiB 
  `Y$$
   `Y$$.                                              
     `$$b.                                            
       `Y$$b.
          `"Y$b._
              `"""

I am more used to dietpi now so not much test on Armbian at my side.
But as I remember, my board is quite stable under Armbian, given that the power is sufficient.

I would also recommend a more conservative setting on CPU governor to prevent the board hang due to thermal issue on both Armbian and Dietpi images.
I attach my current setting as below for your reference.

Generic Device (aarch64) | IP: 192.168.3.243




┌──────────────────────────────┤ DietPi-Config ├───────────────────────────────┐
│ Hardware : Generic Device (aarch64)                                          │
│ CPU temp: 56'c : 132'f                                                       │
│ RAM: 984 MiB | Used: 171 MiB | Free: 813 MiB                                 │
│                                                                              │
│          CPU Governor         : [conservative]                               │
│          CPU Throttle Up      : [70%]                                        │
│          CPU Frequency Limits : Max = [1800 MHz] | Min = [480 MHz]           │
│                                                                              │
│                                                                              │
│                     <Ok>                         <Back>                      │
│                                                                              │
└──────────────────────────────────────────────────────────────────────────────┘

For imaging, I use SD Card formatter and Win32 Disk Imager under windows.

Hope these information could help you and would be glad to have your feedback! :smiley:

Sorry for the delay,

Ive tried a few different power supplies, my laptop uses a usbc 65w charger and I have another generic adapter which claims to be 60w. Unfortunately I dont have a usb power monitor so I cant know for sure what the h618 is getting, but my phone goes into fast charging mode on both adapters, and my laptop seems to treat both equally too.
65w seems a bit overkill for this board anyways, so I made up a 15w 5v regulator to power the board via GPIO (which is how I’d ideally use this board, but I for what I have in mind it wouldn’t be a huge deal to add a usbpd source module)

Im not physically close to my router, so Im sharing the connection via my windows computer (from which Ive been using sd card foramtter and win32 disk imager.) My laptop (linux) has no issues connecting to the internet through all these dongles.

I also found my mini hdmi adapter, although unfortunately I cant capture HDMI.

Having said all this, Im still facing issues.

DietPi is getting somewhere, Ive gotten it to boot but never on the first try. It doesnt really output anything on the serial console, just what I was seeing before and then maybe eventually a login prompt. HDMI shows that its making it through resizing the disk (occasionally it freezes here after the resize itself finishes. If it takes longer than 20min to expand the filesystem 16gb, especially if the heartbeat/cursor stops, I consider it to have failed). Generally it makes it pretty far, it seems to get stuck at time-set.target - System Time Set, the heartbeat keeps going and the cursor is blinking, but after a long time there is no progress.

After many attempts, I get it to boot. Those 3 packages are already held, (I ran the command to mark them as held anyways) and apt upgrade ignores those packages. I also set the governor to conservative, but its still running uncomfortably warm. Im using the heatsink that came in the kit, Ive been working to get my 3D printer going again, and when that happens Im going to work out how to get a fan to cool the board too. (Unfortunately my seller seems to have sent me the wrong metal case and the metal lugs dont line up.)
Maybe it gets too hot during boot? The room im testing in isnt particularly warm, but that might explain why it boots pretty consistently after the governor is set to conservative.

Once it boots, it boots fairly consistently. It just takes a while (45+ seconds) for it to start the networking hardware (something like Job ifup@eth0.service) Different power supplies dont seem to have an effect. I have an img that boots, so I just dd that back onto the sd card if/when something breaks.

Here is a benchmark from that img:

Generic Device (aarch64) | IP: fe80::205:1bff:fe95:d32e
┌──────────────────────────────┤ DietPi-Config ├───────────────────────────────┐
│ DietPi-Benchmark | https://dietpi.com/survey#benchmark :                     │
│  - CPU Performance   : Duration = 10.74 seconds (lower is faster)            │
│  - CPU Temp          : Idle = 61'c | Full load = 90'c                        │
│  - RootFS            : Write = 6 MB/s | Read = 20 MB/s                       │
│  - RAM               : Write = 610 MB/s | Read = 737 MB/s                    │
│                                                                              │
│ Additional benchmarks:                                                       │
│  - Custom Filesystem : Write = Not tested MB/s | Read = Not tested MB/s      │
│  - Network LAN       : Transfer rate = Not tested MB/s                       │
│                                                                              │
│                    ●─ DietPi-Benchmark ────────────────────────────────────  │
│  DietPi-Benchmark  : Starts CPU, RAM and IO benchmark suite. Scores can be   │
│                    ●─ Additional benchmarks ───────────────────────────────  │
│  Custom Filesystem : Benchmark IO performance from a selection of mounted d  │
│  Network LAN       : Benchmark LAN performance using 2 DietPi systems.       │
│                                                                              │
│                                                                              │
│                     <Ok>                         <Back>                      │
│                                                                              │
└──────────────────────────────────────────────────────────────────────────────┘

( Interestingly, im unable to shutdown the system. Reboots work, but shutdown errors out:

root@DietPi:~# shutdown
Failed to connect to bus: No such file or directory

)

I havent had any success with armbian. It always seems to get stuck while booting. After imaging the sd card, it always gets stuck at Starting Journal Service... or [ *** ] A start job is running for Armbian memory supported logging (3s / 29s). Power supply didnt really seem to make much difference here.

em… I hooked my power monitoring dongle on my USB cable, the current drawing from my board was peaked that 0.5A during boot up, with voltage constant at 5V. It’s not a very scary current reading though, but SBC don’t like in hunger :slight_smile:

H618 can run pretty warm, so, yes, I always put a fan on the metal casing which housed the board.
Maybe it’s the CPU temp which block you from accessing the system as I aware your CPU Idle temp and Full load are quite high during dietpi benchmark. (90C is really a scary figure for me).

I am glad that at least you could play with dietpi image. For shutdown issue, I am not aware of that since I only use halt command… sorry I can’t help on this :sweat_smile:
Maybe your armbian image would works once you have your fan in place. Have fun!~